Mikrotik RB532A nebootuje

Mikrotik RB532A nebootuje

Rozhodl jsem se pro koupi nějaké staré desky na seznámení s RouterOS. Na aukru jsem tedy zakoupil routerboard RB532A, dle popisu měl být plně funkční a závady nebyly zmíněny žádné. Jakmile došla deska poštou začal jsem experimentovat a zádrhel přišel hned ze začátku. RB nebyl v defaultním nastavení a tedy nefungovalo defaultní přihlášení. Našel jsem tedy návod na resetování. Přes držení reset tlačítka po zkratování propojky jsem se nedostal nikam dále, RB se prostě nechtěl resetovat a pokud jsem ho resetoval přes propojku, tak se při bootování zasekl. Pouze pokud jsem podržel a pochvíli pustil tlačítko reset, tak RB nabootoval korektně. Bootování se vždy zastavilo na “setting up elf image…” viz výpis ze sériové linky:

Začal jsem tedy pátrat na internetu a moc jsem se toho nedočetl, jelikož má chyba byla poněkud specifická a řešení jsem nenašel. Po neúspěšných pokusech přehrávání RouterOS na různé verze (kromě v6) jsem tedy vznesl dotaz na jedno české fórum, kde by mohl být s RB problém. Shodou náhod mi odepsal nejspíše (soudě podle nicku) předchozí majitel mého RB, tedy prodávající na aukru. Psal, že tento problém má též, že chyba se naskytla po pokusu updatovat RouterOS na verzi 6 a vyřešil ho zkratováním reset tlačítka malým drátkem. Podíval jsem se tedy pozorněji na desku a zjistil jsem, že drátek tam opravdu je, ale na jedné straně odtrhnutý. Při zkoumání desky jsem také zjistil, že již byly měněny kondenzátory na desce. Pátral jsem tedy dál, jak problém vyřešit, jelikož drátek mi nepřišel jako košér řešení. Po vyhledávací mánii jsem se dostal na článek o bootování RB532A na wiki Mikrotiku, kde zmiňují, že v případě problémů s bootaváním se má zkusit přehrát RouterBOOT firmware (BIOS) na verzi 2.9. Provedl jsem tedy nahrání nového firmware a RB ožil 🙂

RouterBOOT 2.9 pro RB532A: rc32434-2.9.fwf
RouterBOOT 2.18 pro RB532A: rc32434-2.18.fwf (nutný pro RouterOS v5)

Comments are closed.